Icinga: Host down, aber Services ok…

Icinga Host-Service-Paradox auf flickr [OC]

Seit einigen Monaten habe ich auf einem meiner Raspberry Pis wieder Icinga als Netzwerkmonitor laufen. Nach Anlaufschwierigkeiten lief das Setup stabil.

Vor einigen Wochen habe ich ein Ubiquiti UnFi Safety Gateway (USG) als Router in das Netzwerk integriert. Seit diesem Zeitpunkt spielte Icinga verrückt und meldete massive Verbindungsschwierigkeiten zu einigen Hosts.

Heute habe ich mir endlich die Zeit genommen, mich des Problems anzunehmen.

Seit der Integration des USG gibt es Probleme mit der IPv6-Verbindung. Das USG und die von Vodafone Kabel Deutschland gestellte FRITZ!Box 6490 verstehen sich bei der IPv6-Delegation nicht richtig.1

In der Folge gibt es Probleme mit Datenverkehr nach Außen, wenn er aus irgendwelchen Gründen über IPv6 laufen soll.

Als erste Maßnahme habe ich daher die adress6-Einträge der betroffenen Host rausgeschmissen. Das brachte augenscheinlich nichts, weil die Host weiterhin als „down“ gemeldet wurde.

Beim genaueren Hinsehen stellt ich die oben abgebildete Situation fest: Der Host wurde zwar als „down“ ausgewiesen, aber die Services waren alle „ok“!

Im (stillgelegten) Monitoring Portal wurde ich fündig: In meinen Host-Definitionen verwendete ich hostalive als Check-Command. In einem IPv4-Umfeld ist hostalive4 (mit einer 4 am Ende) die Wahl.


  1. Es wird wahrscheinlich eine Fehlkonfiguration meinerseits sein. Ein weiteres Problem, um das ich mich mal kümmern muss… 

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Kommentare abonnieren

Es erfolgt keine Weitergabe von Daten an externe Dienste wie WordPress.com.

eMail-Benachrichtigung bei weiteren Kommentaren.
Auch möglich: Abo ohne Kommentar.