Blog im Limbo

Eher durch Zufall1 habe ich am gestrigen Samstag festgestellt, dass sich das Blog mindestens fünf Tage im Limbo befunden haben muss. Es wurde nur noch die Frontpage sowie das Backend ausgeliefert. Alle anderen Aufrufe, d.h. Deeplinks auf einzelne Artikel (z.B. von Google) oder auch sämtliche bloginternen Links auf der Frontpage führten zu einem harten 404-Fehler.   

Da die Frontpage und das Backend noch funktionierten, war ich mir sicher, dass es nicht am WordPress lag. Ich hatte ziemlich schnell die Rewrite-Engine des Web-Servers in Verdacht, konnte mir aber nicht vorstellen, warum diese plötzlich streiken sollte, zumal die .htaccess den gleichen Inhalt hatte, wie die Monate zuvor.

Der Kontakt mit dem Support meines Providers brachte schnell Abhilfe und Erklärung: Da mich letztlich mein Piwik angemault hatte, dass PHP 5.3 nicht mehr aktuell sei und ab Mai nicht mehr unterstützt werden wird, hatte ich meine Site ganz wagemutig auf PHP 5.6 bringen lassen. Da man wohl auf einem out-of-the-box Debian nicht ohne Klimmzüge mehrere PHP-Versionen parallel anbieten kann, wurde meine Site einfach auf einen anderen Server umgezogen. Und dort scheint es noch ein paar lose Enden gegeben zu haben…


  1. ifttt, über das ich meine Blogposts nach Facebook forwarde, deaktivierte das entsprechende Receipt, weil mein Feed über mehrere Tage nicht ansprechbar war. 

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Kommentare abonnieren

Es erfolgt keine Weitergabe von Daten an externe Dienste wie WordPress.com.

eMail-Benachrichtigung bei weiteren Kommentaren.
Auch möglich: Abo ohne Kommentar.